Poll for Confluence outage
Incident Report for Good Software Co.
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 15, 2018 - 15:53 AEDT
Investigating
We are experiencing affecting Poll for Confluence Cloud users. The team is currently working on resolving the issue.
Posted over 1 year ago. Feb 15, 2018 - 15:42 AEDT